ლ(ಠ益ಠლ)

Octopress Install: Could Not Find a JavaScript Runtime

It’s been at least a year since I bothered updating Octopress–I cloned the Octopress source code from git and when attempting the ‘rake install’:

1
"runtimes.rb:51:in `autodetect': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)"

Install nodejs:

1
2
# Assuming you're running Ubuntu or Debian-based Linux OS:
$ sudo apt-get install nodejs

Then:

1
$ rake install

ლ(ಠ益ಠლ)

Comments